Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Video isn't recording properly

Okay, whenever I try to record a video, it won't record it properly. It'll just show one frame from about the middle of the clip for the entire video. Happens with multiple codecs. What am I doing wrong?

Comments

  • edited February 2012
    If CamStudio is running at all, I guess you've got the C++ Runtime libraries from Microsoft OK. Otherwise, get them for 32-bit XP, Vista or 7 here:

    http://www.microsoft.com/download/en/details.aspx?id=5582

    (This is the one you will need - the 2008 version - even if you have a 64-bit machine)

    Go get and install Jawor's Xvid, using his HD720 profile, with the Xvid quality slider all the way to the left (at 1) or perhaps up to 4. Be certain to click the "Other Options" button at the bottom of the configuration dialog and un-check the "Display Encoder Status Window" check box.

    http://jawormat.republika.pl/xvid.html

    Use these settings: Set Key Frames Every: 30 to 200; Capture Frame Every: 40ms; Playback Rate:25fps. Those should work. Use MCI for recording in the "Audio Settings for Microphone" and set it up to use Stereo Mix if recording games.

    See videos at http://www.youtube.com/playlist?list=PLA57A11C0D77BBF9B&feature=plcp for more information.

    Terry
  • Hm...downloaded it, installed it, but Xvid won't show up in the "video options" window.
  • You may have to restart your machine for it to show up. It works with all versions of CamStudio.

    Terry
  • Still not showing up. I mean, after I installed it, I noticed the shield thing next to the shut down button on the start menu (oh, I have Windows 7 if that's important at all), but after restarting twice it's still not there.
  • edited February 2012
    Wait - did you install the 32-bit version? It won't show if you only installed the 64-bit version. CamStudio needs the 32-bit version. (You can have both installed.) Sorry, I usually remember to mention that, but I forgot to this time.

    Terry
  • edited February 2012
    It seems to be working now. However, I've noticed somewhat of a bug. When I try to select an area of the screen with the selector tool, Camstudio doesn't want to record that area - when I hit record, it's recording an entirely different area of my screen. Then, when I try to change the place where it's recording, the screen goes all tilted. Happens whether you pause the video and try to change it, or you just drag the selection nubs elsewhere. It's annoying, but if there isn't a fix, I think I'll still be able to manage. (Also, I got something where it said it couldn't record with that codec, but I remembered you saying somewhere that Xvid doesn't like odd numbers, so I just went into the fixed region options & changed the dimensions)
  • Yes - this is normal for any MPEG-4 type of codec. They all require that the height and width be divisible by 2 (DivX requires height be divisible by 4, in fact).

    Use the "Region:Fixed Region" menu item instead, and while in there, press the "Select" button and it will let you select an area. Then you can correct the values in the height and width box before starting the recording.

  • When you go to record, you've got to move the rectangle that appears over the section - which is fiddly, I admit. That's why I use Sizer and record a Window region instead now, but with some video cards you have to subtract 1 from the width and height in Sizer to make the proper size.

    Terry
  • Well that's what I'm saying. When I try to use Region:Fixed region, the area that I select isn't what gets recorded. And when I try to drag that rectangle around, the video screws itself up. I mean, I can deal with it just by dragging the window I want to record into the area, it's just a bug that I thought I should mention.
  • Are you dragging before or after starting the recording? There is an option called "drag corners to pan recording" there you can try to enable (or disable if that's the problem!) it allows you to pull the green-flashing corners to pan, but that feature breaks on my machine pretty badly!

    Terry
  • Okay, I've got it working now, and I'm trying to do that thing with the stereo mix, but here's the thing. I have a headset (headphones + mic) that plugs into my computer via USB. I don't have the line-in thing in any of my menus. Also, I only have two sliders in the Sounds>Playback>Speaker properties>Levels menu: Realtek HD audio output + microphone (this might be because I'm doing this on a laptop, but I don't know).
  • edited February 2012
    Laptops are notorious for their limited options for audio input and output. You are very likely out of luck finding a Stereo Mix in there, even as a registry entry hiding it.

    Other than that, what did you do that made it work to record?

    Terry
  • No, I have Stereo mix in there, it just doesn't have the Line-in thing in any of the menus.
    To record it, I set the mic on my headset to the default device and it worked.
  • edited February 2012
    Fantastic! At least we have that much working. Sorry you don't have mixing ability, but that is a bit of a hack making it work on Windows 7 on ANY machine!

    Terry
  • Yo, TB, I got the speakers thing to work, but I'm having a little bit of trouble. It records everything just fine, there's just this faint echo thing as my mic records a bit of the speaker's output.



    Anything you would recommend to cut down on that, settings-wise? The main output on my speakers is set to 86, and the mic's settings are at 80.
  • Yes, keeping the mic clear of the speaker output is not easy. That's why I flipped when my version of Realtek allowed me to turn down the speaker volume separately from the signal level sent to Stereo Mix.

    Too bad we don't have access to the kind of speaker-cancelling tech that Skype uses now!

    Terry
  • With a Win 7 (64), and with the 2008 C++ installed, is there any way to get any use of audio from speakers? I'm trying to record off the screen and using the machine's audio output.
  • edited August 2012
    If you have Stereo Mix available as a Recording source, you can activate that. Not all machines ship with that available, though. You then can use "Record from Microphone" with Stereo Mix as your source.

    Some rare people are seeing the "Record from Speakers" option work again in their Win7 setups, so feel free to give it a try! Don't hold your breath, though!

    If you have a line-in jack but no Stereo Mix, you can get a patch cord and place the line-out into the line-in, then select line-in as your recording source. A workaround, but viable.

    Terry
Sign In or Register to comment.