Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

File format


I am new here: I just tried Camstudio 2 days ago. Seems exactly what I need, excepted for compression format:

The first times I used it, I did not modify anything excepted default directory and the files I saved appeared as "24 bits", "not compressed" with PCM audio. They were pretty large, but they are what I want. After trying different codecs for compression, I can't now find how to save same uncompressed files: even the temporary video file (when looking in Temp directory before saving) seems to be compressed.
Is it possible to save in "no compressed" format, or I have to install again?

Sorry for my frenchy English,


  • shadoko,

    The lossless codecs like CamStudio Lossless and Lagarith Lossless do what they say - no real compression, just file-size compression. The video springs back to uncompressed upon playback. But, the videos you can make are short with those, as they take tons of space up.

    You are limited to 2 gigabytes in file size, and that includes your audio, which if you follow my recommendations elsewhere, would be set to "Use MCI to record" or PCM 16-bit, 44.1MHz audio.

    There is no "raw" option in CamStudio by itself, but you can load a lossless codec file into VirtualDub and export it as raw if you so desire.

  • edited November 2012

    Thank you for your answer, but I think I didn't use the right words to explain "my" problem:
    There is a screenshot of the properties of the first file I saved :


    As you can see, the file was "no compressed" ("Non compressé" in French). To make this AVI file, I didn't change anything in "original" Camstudio except the screen region I wanted to capture.
    And yes, the file is very large for its very small time length (206Mo for 31 seconds), but this is not a problem for me.
    And after looking at the codecs, I was not able to save another AVI with theese properties, as if before choosing a codec, no one was used, and after the use of one of them it was impossible to return to the original settings.


    Sorry for the link, I don't know how to post a picture there.
  • shadoko,

    Thanks for the picture!

    However, I have no idea how you achieved that result. Very odd not to have a compressor listed. It may be a glitch in how the info is written to the video.

    If you use a lossless codec, be aware that even with Lagarith Lossless (the superior of the two, CamStudio being more like "zip for video" according to Nick), you will get only 9 minutes of video with syncable WAV PCM audio. Over that and it exceeds the 2 gigabyte file size limitation imposed on us for still using AVI-1 spec.


  • edited November 2012
    Hi Terry,

    I tried to reinstall** CamStudio, and YES, the files are, as the first time, saved in what it appears (to Windows file properties) as "not compressed" (same properties as in my November 24 post picture).

    I looked at the file with VLC and I post below a picture of the codec tab in "Media Information":


    For VLC, codec is "24 bits RGB (RV24)". Is it a raw codec? How to "tell" to CamStudio to use this one (after "looking" in the CamStudio video codecs)?

    Curiously, the "Description" shows the name of the temporary file (Description: ~temp-20121127_0221_13.avi for "video#1") although this file doesn't exist anymore: it has been automaticly replaced by 20121127_0221_13.avi*** when the capture finished, "mixing" this video file with the audio one to produce the "final product". Perhaps this is written in the file, I don't know anything at all that (and sorry for this).

    Any idea?


    ** I didn't uninstall nor erase the first installation, but I installed with another name from another disk.

    *** I changed it in 20121127_0221_13aaa.avi to verify the VLC "Description" info stays unchanged, so is it this name which appears in "Location".
  • shadoko,

    Hmmm.... well, I know the temp files themselves are some kind of raw format, without keyframe info applied yet, though. (Or I assume as much from my recovery successes in VirtualDub). I've never heard of anyone using the temp files for any purpose, however.

    This is mysterious, and I'm afraid I do not have a clue. I'll ask the developers to take a look at this thread.

  • @Shadoko
    I noticed that you was collecting video with 200 FPS. (See the image link).
    25, 30, 50 of 60 fps gives you a much better performance.

    The ~temp*.avi files are the video capture files but still without sound. If required sound is mixed afterwards or file is just simply renamed..
  • @shadoko

    What version of Windows are you using? Is it 64-bit?

    Is there any chance you could uninstall, then reinstall CamStudio and before you do anything, you could take a screenshot of your default video and audio settings in CamStudio and post them up so we can all see?


    Nick :o)
  • Hi,

    Thank you all for your answers.

    I use WIN XP sp3 (32bits). I have uninstall and reinstall. Please look here: http://www.ratier.org/archives/transfert/CamStudio/index.html
    There are screenshots (with new installation) and an AVI file (link at the bottom of the page). I tried to make all the same that the first time.


    @Jan: 200FPS is the default setting. I tried others, but want to keep the same settings that I use when I first obtained a "not compressed" file for this thread.
  • A couple comments based on your screenshots:

    If you’re trying to analyze what you’ve produced after the fact, you need a more suitable program to do it. Something like GSpot will do nicely, if you don’t have a video editor.

    If your video props dropdown screenshot is an accurate reflection, you’re using Cinepak as a codec. This is an obsolete codec and was never very good anyway. Of the choices you have available on your computer, Xvid MPEG-4 is the only usable one.

    You need to change “record audio - speakers” to “record audio - microphone”.

    There may be a good argument for not selecting “ask for file name” if you’re sending all output to the same folder, and if your CamStudio version overwrites existing files without notice (as mine does) but otherwise, it’s better to set “ask for file name”

    Your test video is too large a file, considering it is so short and so small a capture area. Something of usable size would take you over the 2 GB file size limit in a very short period of time.

    Your 5/200 setting is very good for capture, but media players will choke on the 200 FPS, so you’d need to convert to 25 or 30 FPS after the capture is made and processed.

    To Terry: The issue of being able to parse a binary file without actually trying to process it using the intended application it is an interesting one. If one knew how to do it, the “lost file” situation might be solved. Seems to me like it would require some sort of “dedicated” software designed expressly for that purpose. Wonder if such a thing exists?

  • @Ken: Thanks for answering, but "If your video props dropdown screenshot is an accurate reflection, you’re using Cinepak as a codec.". It is what could be believed, but it is not the codec in use: look at the file I saved after doing all what is on the screenshots, please (I hit the 'Cancel'button after accessing video options). It is the problem for which I came here: before choosing a codec, it seems no one is in use (at the least, not one of the compressors proposed in CamStudio list). After choosing one, and hit the 'Save' button, it is impossible to return the software to its original state (but reinstalling is easy!).

    About the other remarks: I understand what you tell, but, please, read my first post.

  • I don’t know exactly how you did it, but what you came up with is a Microsoft 24 bit uncompressed DIB file. My guess is that hitting the cancel button is not the way to choose a compression option with any predictability, so it’s best to have a codec which gives you a DIB option. The most common is ffdshow with “uncompressed” selected in the compressor window. The problem is that your current CamStudio is not seeing that codec, but I can’t tell you why. I don’t know if the Cam lossless or Intel codecs you have give you that option, because I don’t have them. I think my ffdshow codecs came with the K-Lite mega pack I downloaded and never went away when I got rid of most of it, so you might try that source.

Sign In or Register to comment.