This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

CamStudio 2.7 Bug Reports and Installer Issues



  • edited March 2013
    The CHM files, to my knowledge, have not been implemented at all yet. The HTML help files from 2.0 would work from the help menu if they were present. You can still get 2.0 from our Sourceforge project site in the folder marked "Legacy."

    Just install that along with 2.7 and copy the folders over. The two programs can actually be used at the same time, IF you open 2.7 first, followed by opening 2.0. BUT 2.0 uses the older C++ runtime libraries from 2008, so you'd need those as well.

  • Hi, I have a problem installing the software. I have tried 3 times but keep getting an error which says 'The program can't stat because mfc100.dll is missing from your computer'.
    I have reinstalled it twice, but I get the same message.
  • Keith,

    See this post above:

    You need this version (the x86 version) even if you have a 64-bit machine.

  • Thanks Terry,
    I've sorted that.
    When I record full screen, I now get a crazy flashing screen, that goes different colours!

  • In Options/Program Options, check "Hide Flashing Window During Recording". That runs in a separate process - be certain if your CamStudio minimized during recording to stop it from the TRAY and do NOT attempt to end it from the task bar by closing it - you'll get crazy stuff then.

  • edited March 2013
    An "advanced" computer user here. Found CamStudio and wanted to give it a try. Downloaded and installed (from Sourceforge) CamStudio_2.7_r316_setup.exe on Windows 7 SP1 32-bit (with all Windows Updates & hardware drivers updated to this date).

    No mfc100.dll issues (I manually extracted it from the free Microsoft Visual C++ 2010 Service Pack 1 (09-08-2011) redist from the MS Download Center and put it in the CamStudio directory). It started and ran and recorded fine. brought up by others in a couple other threads, the modern CamStudio simply can't find any modern codecs installed on my system on its GUI dropdown list. It can find the ancient Cinepak, a couple of Intel Indeos, MS Video 1 and that's about it.

    The modern codecs properly installed here but not found by CamStudio 2.7 (but can be found & used properly by MPC-HC, VirtualDub, SMPlayer and so on): x264vfw (my favorite), Xvid, ffdshow's encoder & a circa 2003 Windows Media Video 9.

    So, went into the command line app and ran it to see what it detected. Sure enough, it did in fact detect all of those modern codecs in addition to the old ones that could be seen in the GUI dropdown. Setting the command line app's options to choose one of the modern codecs at a time (started with x264vfw), it started to run, then the text stopped (its been 2 weeks since I uninstalled 2.7, forget the exact details). Never produced usable output. Running with one of the old codecs though (i.e. MS Video 1), the command box filled with text for as long as it recorded and it produced usable output.

    Of course, running the command line app gives video without sound, so not really usable, even if it did work properly with the modern codecs.

    So after a few hours of trying to get the modern codecs to work with either the GUI or command line app (uninstall/reregister, only install one at a time, etc. etc.), I uninstalled 2.7 and tried CamStudio_Setup_v2.6b_r294_(build_24Oct2010).exe, as suggested by another thread. Unfortunately, identical problems as 2.7.

    So for the last try, installed the circa 2004 CamStudio 2.0 ( from Sourceforge). Guess what? It properly detects and can use all the modern codecs (properly) installed on the system here. In addition to the obsolete ones that v2.6-2.7 could only use.

    Here is hoping that future modern CamStudio versions can finally detect & use codecs properly. Any suggestions as to anything I may have overlooked (not detailed above), it would be appreciated. Not really needed here though; version 2.0 detects and uses everything properly without issues.

  • Hmmm, actually, 2.7 eliminated the "missing codec" problem. It cannot see 64-bit codecs, of course, but they wouldn't work on your 32-bit system for any program, so I doubt you've installed any of those.

    I use Xvid every day. Nick uses ffdshow. I cannot imagine why it is treating you like this!

    Please re-install 2.7 and take a look (2.0 and 2.7 can be installed separately, and even run at the same time if you start up 2.7 first...)

    In other words - you experienced an anomaly that is unique to your setup at that time. I'm hoping a re-install fixes it. Also, do install the entire 2010 runtime libraries - it may be needing more than only mfc100 from there.

  • edited March 2013
    Thanks for the reply.

    No, as expected, a reinstall of CamStudio_2.7_r316_setup.exe has not fixed anything. The "missing codec" problem is not eliminated with that version, it has the problem...heh. Can more exactly let you know the only (obsolete) codecs the Options, Video Options, Compressor drop-down list shows, however. Microsoft Video 1, two instances of Intel IYUV Codec & Cinepak Codec by Radius. That's it.

    Of course no 64-bit codecs are installed or running here. If there were, there would be problems running them in other applications here on the 32-bit OS, which there are not.

    As to the C++ runtimes, running recorder.exe through Dependency Walker (, it only uses three VS2010 files: MFC100.DLL, MSVCR100.DLL & MSVCP100.DLL. The last two I already had in \windows\system32 for other programs here that needed them, thus why I extracted the first one to the CamStudio 2.7 directory. Doing so, no issues running the program, other than the missing codecs.

    But after the continuing failure of 2.7 to find the properly installed codecs, I did as you suggested and installed the entire (32-bit) VS2010 thing (from instead of just the files it uses (ugh). No difference, as expected.

    2.0 still continues to properly show & use all installed codecs (as noted in my first post), 2.7 doesn't. Oh well.
  • Well, I don't know how many times I need to repeat this - 2.7 repaired the missing codec problem... So, my next suspicion is that you have a shortcut still opening up 2.6b - check the "About" box to be sure. Nobody else but you has reported this problem, so I'm a little stuck without a precedent to compare details.

  • No, 2.6 isn't installed.

    Perhaps testers and/or users here are are only using 64-bit OSes? That's my suspicion.

    Output from 2.7's CamCommandLine.exe:

    Valid codecs on this machine:
    0: Microsoft Video 1
    1: Intel IYUV codec
    2: Intel IYUV codec
    3: Cinepak Codec by Radius
    4: ffdshow Video Codec
    5: Intel Indeo(R) Video R3.2
    6: Intel Indeo(R) Video R3.2
    7: Intel Indeo« Video 4.5
    8: Indeo« video 5.10
    9: Microsoft Windows Media Video 9
    10: Xvid MPEG-4 Codec
    11: x264vfw - H.264/MPEG-4 AVC codec

    Only 0,1,2 & 3 show up in the GUI dropdown box, as noted. And also as noted in the first post, only those + the Indeos produce a usable AVI (without sound) when started with the proper command line options (i.e. CamCommandLine.exe -codec 0 -outfile test.avi -seconds 5).

    Instead try to run that with Xvid (10) above, it starts, but unlike the older codecs, it doesn't scroll "nextFrameAt: 21758960, timeGetTime: 21758951, toNextFrame: 9 Sleeping for 9 msec (21758951 - 21758961)" and so on. Instead, get this:

    Using codec: Xvid MPEG-4 Codec
    Detected displays:
    Screen: \\.\DISPLAY1 resolution:1151 x 863
    Creating recording thread for screen no.:0...
    Recording to: test.avi_.avi
    Recording for 5 seconds
    Waiting for recording thread to exit...

    When the prompt returns, the AVI produced is 0 bytes and is unplayable.

    BTW, in order for "-seconds 0" to work, you have to type it in like "-seconds0". With the space, "Expected valid number of seconds to record: 0" pops up and nothing is recorded. Not entirely clear.

    Final testing: sure enough, x264vfw (11) does now produce usable output from the command line option. "camcommandline.exe -codec 11 -outfile test.avi -seconds 5" produces a 252kb H264 file that's playable.

    So there is that. But not usable compared with 2.0's working GUI that provides full sound. GL.
  • No, users are from all over the map - XP, Vista, Win7, Win8, 32 and 64-bit.

    Curious display resolution - those odd-numbers will not work with Xvid or x.264 or Divx, as the first two require multiples of 2 for width and height, and Divx needs a multiple of 2 for height and a multiple of 4 for width. So, full-screen capture would never work here. The command-line interface probably does not throw up error messages about that either. Of course, that read-out could be wrong, too. What are the dimensions of the playable x264vfw video that you managed to get?

    I still say, pull out CamStudio and the runtime libraries, reinstall from scratch.

    I use this version of Xvid by Jawor -

    VirtualDub's Video/Compression tools may come in handy here.

    There definitely seems to be something wrong with this installation. Yours is an isolated incident, I'm sorry to say. 2.7 is showing codecs.

    See if 2.6c is working - it has the same fix for the codecs:

    It also uses the 2010 32-bit runtime libraries.


  • edited March 2013
    "Curious display resolution - those odd-numbers will not work with Xvid or x.264 or Divx, as the first two require multiples of 2 for width and height, and Divx needs a multiple of 2 for height and a multiple of 4 for width. So, full-screen capture would never work here. The command-line interface probably does not throw up error messages about that either. Of course, that read-out could be wrong, too. What are the dimensions of the playable x264vfw video that you managed to get?"

    The first two codecs work & record without issues in CamStudio 2.0 (and VirtualDub). I use a (high quality) 4:3 CRT monitor, explaining the odd dimensions (which I prefer).

    Output dimensions of 2.7's "camcommandline.exe -codec 11 -outfile test.avi -seconds 5" AVI (x264vfw): 862x864 (0.998). It shrunk the horizontal dimensions by 25% in the playable AVI. No error output.

    However, running CamStudio 2.0's GUI x264vfw dropdown option, it provides AVIs with the full desktop dimensions of 1152x864 (4:3).

    Using (the standard version) Xvid with CamStudio 2.0 (not possible in 2.6b & 2.7), the AVIs it produces also have a proper full desktop res of 1152x864 (4:3).

    "I still say, pull out CamStudio and the runtime libraries, reinstall from scratch."

    Continually reinstalling programs to try to resolve issues is a beginner's solution which is inapplicable here. I've already reinstalled (and tested) 2.7 and provided the results in the post above. I also fully installed the VS 2010 C++ redist pack (inapplicable as all the files 2.7 uses were already installed properly) and confirmed that all the files were properly deposited in the correct locations; results in the post above. No change.

    As mentioned in prior posts, I already have & run VirtualDub with no encoding issues.

    As to CamStudio 2.6c (while 2.6b & 2.7 have the same issues here), I'd rather spend time doing more useful things than seeing yet again if the problem is on my end. Might (or might not) try it later.

    Thanks for your help.
  • Sure, sorry I couldn't solve your unique situation. If you get to the bottom of it, please do let me know in case I encounter this in the future.

  • edited March 2013
    I have since installed 2.6c. As in uninstalled 2.7, downloaded Camstudio-2.6c.7z, unzipped the files (with 7-Zip) into proper folders. Started up Recorder.exe...exactly the same problem as 2.6b & 2.7's video option dropdown. Only four codec choices (MS Video 1, 2 x Intel IYUV Codec & Cinepak Codec), not anything else. While CamStudio 2.0 continues to provide all the proper choices in its video option dropdown.

    In the interest of finding to see what bug outs that dropdown in 2.6+ here, I also changed the desktop resolution here temporarily from 1152x864 (true 4:3) to 1280x720 (16:9, 720p). No change in 2.6c.

    Perhaps 2.6c/2.7 hasn't totally fixed the dropdown issue in all cases. Or (less likely), using the latest builds of VS2010 C++ files here as noted above (file versions 10.0.40219.1) is causing issues where older builds you compiled against do not. Wouldn't bet on it, though, they should be backwards compatible (and no other program here that uses them has issues). Also, if 2.0 also exhibited similar behavior, I'd definitely say its an issue on my end. But it doesn't.

    Also unusual in the code changes you've made in 2.6+ is that is that 2.0 has no issues with original Xvid or x264vfw providing full 4:3 1152x864 output. But 2.7's camcommandline.exe fails to provide output with Xvid and it shears 25% off the horizontal dimensions of x264vfw video.

    Oh well, thanks again; look forward to future versions that may resolve the problems.
  • Yloh,

    There is a new version coming out pretty soon, so keep an eye out for that. I hope what may be causing this on your system reveals itself to the programmer as he works on other issues also being fixed. 2.6b had all the issues you are having, and 2.6c and 2.7 had fixed the missing codecs issue for pretty much everybody, so I can only speculate (not being the programmer) what could be making it fail for specific configurations. Maybe we'll get lucky and something done to the upcoming version fixes that for you. I certainly hope so.

    Meanwhile, the basic functionality of 2.7 is inherent in 2.0 - only a few features are lacking that were added (capture windows, full screen and some other convenient things that were added). I hope in the meantime you can get your work accomplished using 2.0. If you have any questions as to best setups for certain types of projects, I'll be happy to help out there.

  • Hello

    I appear to have this same problem of mfc100.dll not found despite following your link above to download the 32-bit "MS Visual C++ 2010 Redistributable Package" where your link points, and installing the software. The error persists after a reinstallation of CamStudio, a reboot, and so on. I use Windows 7 SP1, 64-bit on a dual-core laptop.

  • This is 2.7 we are discussing here? (2.6 needed the 2008 version of the MS C++ runtime.)

    I have both versions working on a Win 7 64-bit machine here.

  • edited April 2013
    I downloaded whatever your link said two days ago on your download page at "". Yes, I believe it was 2.7.
  • Try this one in case my version is different somehow from what is up at Sourceforge presently:

  • Also, we could try installing both the 32 and 64-bit versions since you have a 64-bit machine. I happen to have had both installed anyway, so I never saw an install of 2.7 without those both being present.

  • I just installed the current version of Cam Studio. I'm running Windows 8 Professional 64 bit. When I launch it and switch focus to the application I'm capturing I get a Wave In error. When I click the OK button I get prompted to use the default compressor. If I say Yes, I get the Wave in error again. Is Cam Studio compatible with Windows 8 Professional? If not, is an update coming?
  • I don't know - I've heard of people getting it to work OK, though. Are you capturing audio from microphone or trying "audio from speakers"? I'm quite sure "audio from speakers" will not work - since XP SP2 most folks have needed to use Stereo Mix in conjunction with "audio from microphone" - the 2.7 tutorial video at my channel covers the settings:


  • Hi,
    After the install (good) of 2.7 r316, I have an error recorder.exe(see picture above).
    I uninstalled 2.6.b and I cheched into App roaming (nothing).
    I downloaded and installed several times to see but nothing to do.
    I'm under Win64 Pro France. (ASUS P5Q PRO Q6600 8GBDDR3 OCZ VERTEX3 120)
  • That's mysterious alright... I take it you are running it directly from the program files folder (and not from an old shortcut)? You might try re-installing the C++ runtime libraries just as a guess -

    I'm a bit surprised you found no camstudio.cfg file in appdata/roaming.

  • When I pause and resume a recording, the audio starts to come sooner than it should.

    The fragment before starting up to the first pause is perfectly synchronized, but after that the sound comes a small fraction before the image.

    If there's no pauses the audio remains in good synchrony thorough the video.
  • Yes, I also have found that pause is causing this type of behavior - no idea why. I'll notify Nick that we have another bug to squash!

  • @Midichlorian, can't you use the Force to resync them? ;)

    OK I'll speak to my programmer then ...

    We're on the case ...


    Nick :)

  • "That's mysterious alright... I take it you are running it directly from the program files folder (and not from an old shortcut)? You might try re-installing the C++ runtime libraries just as a guess -
    I'm a bit surprised you found no camstudio.cfg file in appdata/roaming.

    Thanks I reinstalled and It works.
    And now I have the camstudio.cfg file in roaming.

  • Good, good... puzzling how you had no config files in there before!

  • I just downloaded the latest (CamStudio_Setup_v2.7.2_r326_(build_19Oct2013)) version and cannot get it installed on a Windows Server 2008 R2 64bit VM. I had been using the older 2.0 with no issues for a long time and wanted to see if there was an update.

    I tried running the installation as an Administration with no luck. I also ran it as an Admin in compatibility mode using Windows Server 2003 (sp1), Windows Vista (sp2), Windows Server 2008 (sp1) and Windows XP (sp3) to no avail. When the initial box comes up, it just sits there for a bit and then the standard Windows crash dialog comes up. If I try to move the box, it doesn't move until it's "released" at which point the crash occurs.

    I was able to install it on a Windows 7 64bit VM with no issues.

    Here's the Event Viewer info I found which I hope is helpful.

    Faulting application name: CamStudio_Setup_v2.7.2_r326_(build_19Oct2013).exe, version:, time stamp: 0x2a425e19
    Faulting module name: KERNELBASE.dll, version: 6.1.7600.17206, time stamp: 0x50e6605e
    Exception code: 0x0eedfade
    Fault offset: 0x0000c41f
    Faulting process id: 0x11c8
    Faulting application start time: 0x01ceef6f0096b8aa
    Faulting application path: D:\installation\CamStudio\CamStudio_Setup_v2.7.2_r326_(build_19Oct2013).exe
    Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
    Report Id: 4fd5f374-5b62-11e3-83bf-005056900019
Sign In or Register to comment.