Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Mute Built In Microphone?

edited August 2009 in Support
CamStudio is excellent. However, I am having difficultly finding a way to mute my built in microphone while still recording audio of the person on cam.

I have tried right clicking on the audio icon on the task bar and going to recording devices and disabling it there, but then it won't work at all. The thing I am disabling there is called Microphone Array (SigmaTel High Definition Audio CODEC).

I have also tried options in camstudio and then record from speakers but my mic is still recorded as well.

I am using Windows Vista.


Thank you for your help,
Joe

Comments

  • Joe

    Try this:

    Right click speaker icon in systray > select Recording Devices

    Double click Microphone description > Levels tab

    Click the little speaker next to the level slider.

    If that doesn't work, drag the slider to the far left hand side.

    Cheers

    Nick :o)
  • Thank you for your reply. Your step by step did work but unfortunately, it also muted the sound of the webcam as well. I hope there is a way to mute my built in mic without muting the audio from the streaming webcams.
  • Any other ideas?
  • This still is not working. Someone please help. When I move slider to zero it does not record my built in mic, but it also does not record audio from their cam (even though I can hear them while I record).
  • I have been dealing with the same problem with a Dell Inspiron 1525 and there seems to be absolutely no solution what-so-ever.
    The problem lies with the functionality of the sound card driver. in my case it is Sigmatel HD Audio. It just doesn't have any separate control of the built-in mic. with Vista or 7, you only see control for "Microphone array" which is basically the entire sound card.
    I am trying to record the Jim Rome show which airs while i am working and so never get to listen and the noise from the built-in mic is too annoying to even bother listening at all.
    I was hoping the problem would be solved when I upgraded to Windows 7. I uninstalled the soundcard through the Device Manager immediately before upgrading so that Windows 7 would detect the soundcard and install the appropriate drivers automatically. My hope was that the new drivers would have more functionality than the drivers I had previously gotten directly from Sigmatel.
    Now my Device Manager shows "Intel HD Audio HDMI" instead of Sigmatel, but the functionality is exactly the same. Just "Microphone Array". No "What You Hear" or "Wav".
    So, this leaves 2 choices. buy an external soundcard that has more functionality or cut the wire from the mic.
    since I don't need the mic at all, I thought the second option might actually be a viable solution.
    NOT!
    After taking off the display bezel to get to the built-in mic I noticed the mic is actually 2 mics located on either side of the built-in webcam. There is basically a small ribbon cable with 6 tiny wires going into the webcam/mic unit with a connector similar to the connector that attaches the keyboard or display to the motherboard, just smaller. Now I am thinking "GREAT!" all I have to do is disconnect this cable and the mic will be disabled (the webcam also, but for now I just want to be able to record my show) and what-do-you-know, when that cable is diconnected the entire "Microphone Array" is disabled the same as if I muted it. Sound still comes from the speakers, but nothing at all can be recorded.
    UNBELIEVABLE!
    Maybe I can just cut a tiny wire right at the mic's base?
    NEGATIVE!
    both mics and the webcam are all attached directly to a tiny circuit board (NO WIRES!)

    So, I believe I have exhausted all options here short of buying an external soundcard and that's not gonna happen!
  • edited February 2012
    It is really frustrating the built in microphone pick up all kinds of sound around you. After a lot of try-and-errors, I finally figured out a way, it worked for me, and hopefully, it will work for you should you have the same problem:
    1. Control Panel
    2. Sound
    3. Recording
    4. Disable notebook microphone
    5. Enable Realtek microphone
    6. Ok
    7. Plug in a dummy plug into the computer microphone slot (Preferably a cut-off portion from an unwanted microphone. I am using a earphone plug, fortunately my computer is not burnt out).
    8. Done.
    9. You can always replace the dummy plug with a working microphone when you actually want to have a voice chat or recorded. I almost never use the built in microphone, it gives a muffle sound anyway.
  • Also if your PC's BIOS supports it is to disable the built-in mic - normally by press F2, F12 or another function key before the PC boots into Windows.

    Cheers

    Nick :)
  • Ahh - the old "dummy plug" trick! Haven't seen that one in years!

    Great solution, Yohan!

    And I never would have thought to disable an internal mic from the BIOS.

    Terry
  • Might be relevant, might not be (this is in Windows XP) but ...

    Pop up the Windows Volume Control, then go to Options, Properties. If you find you have more than one device listed in the Mixer Device dropdown, you might find that one or more are input devices while the others are output devices. Select what looks like the approriate input device (can't help you with that) and you'll find that Microphone is listed as one of the inputs. You can work out the rest.

    The secret is to understand two things: input devices are not output devices (something which seems to have escaped MS's attention) and that thing in front of you is a laptop computer, not a high-quality dedicated recording console.
Sign In or Register to comment.