Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Lossless codec executable file?

edited July 2011 in Announcements
I'm pretty confused here. I've read the instructions and watched tutorial videos. I have clicked on "CamStudioCodec14.exe" to install the lossless codec. This takes me to a file directory of available downloads with only one .exe file: "Camstudio2-0.exe". All others are zip files. What gives?

Next, plan B. I clicked on "CamStudioCodec1.4.zip", downloaded and extracted. I looked for "camcodec.inf". There are no files in the folder ending with ".inf".

Anyone care to put me out of my misery? :-) Thanks!


  • Iontano,

    I thought I had noted in that video that the .exe wasn't available any longer - I'll fix that. Meanwhile, you can use the copy I keep at http://screencasttutorial.org/CamStudioCodec14.exe - that is a copy of the one that used to be on the CamStudio servers. When the files were all moved to Sourceforge, that one went missing.

    Still, after doing that, use the latest version anyway - v2.6b r294 - it installs CamstudioCodec 1.5 - if that doesn't show up, reinstall 1.4 again and then reinstall 2.6.

    Watch the videos!

    I would download Jawor's Xvid or Lagarith Lossless if you are doing any motion recording. CamStudio Lossless is only for tutorials with static screens.

  • Thank you, Terry!
  • thanks a million for the exe file. I tried over and over to install/load the zip file. Thanks very much
  • tomasred,

    Glad it worked!

  • tbritton,

    Thanks so much for providing the link. After all the other times I've tried to install, it finally appeared.
  • theoneandonly09,

    Glad to see it worked for you, too! :-)

  • I'm so confused with CamStudio. I've downloaded it so many times, I don't even know. Always get the message "error creating avi file." I just checked here and someone said to right click and run as administrator and finally, that worked. Now I see all this info about lossless codec, but I don't understand what that is. Do we need it. I'm assuming it at least enhances the program. Thanks .
  • You usually get that message if the file is too large, as there is a 2 gigabyte file size limitation in the AVI-1 container which the 2.x versions of CamStudio use.

    You do not need a lossless codec, most likely. You will need a good compressor, like Xvid. Or use Cinepak, or Intel IYUV - just not Microsoft Video 1, which sucks pretty hugely.

    Be patient - watch the videos linked to in the sticky above - and we're always here to answer your questions. Everybody doesn't know until they know.

  • I feel like such a clueless noob sometimes! I'd been using the CamStudio Lossless 1.4 codec with the 5/200 framerate setting for the past year, because I hadn't figured out that I needed to unclick the "Auto Adjust" tickbox in order to be able to change the framerate setting. I've since experimented with different framerate settings, and both 25/40 and 40/25 seem to still look pretty good recording gameplay footage from a Windows game published in 2000 (Heroes Chronicles); maybe other framerate settings would look good, too - I just haven't tried them yet.
    I've also experimented with some of the other codecs which showed up in the list of choices under "Video Options" (after installing the K-Lite Mega Codec Pack). Xvid seems to playback with a black screen (maybe I'm doing something wrong?); however, Cinepak did work fine - and seemed to compress a 4-minute test recording to about 1/3 the size I was getting with CamStudio Lossless 1.4. So I'll next try using Cinepak for my usual 20-25 min. long YouTube episode, and see how the file size and playback quality compare to my old settings.
  • CatherineMcClarey,

    Great to hear about Cinepak - I've not used that myself yet, but I've heard other game recordists say that they liked it for games.

    I do use a specific flavor of Xvid - Jawor's Xvid - with the 720HD profile he provides. I've never gotten a black screen - what media player was that?


    Let me know how it goes with Cinepak - there really aren't any settings for that, are there? Just color or black & white, correct?

  • That was with CamStudio's own Movie Player 2.1, which opens the just-recorded video (from CamStudio 2.0) once the audio's compressed.
    I'm not sure what flavor of Xvid I have; it just showed up in the list after I downloaded & installed the K-Lite Mega Codec Pack (got it via CNET Downloads).
    You're right about Cinepak; there are no settings to configure (other than selecting "compress to color" or "compress to black & white"). Makes it pretty goof-proof that way (as long as it works for what one needs). I think I will still want to use Any Video Converter to compress the recordings further (to FLV or maybe MPEG4) while recording the "Heroes Chronicles" series; however, with some DOSBox games (such as the "Gold Box" series of Dungeons & Dragons-based games I've also recorded), I may be able to upload the raw AVI files of future recordings without converting - as long as I use the Cinepak codec with CamStudio.

    (Some of my commenters on YouTube have complained about the FLV files I upload being at 240p, and have suggested that uploading in a different format might allow the recordings to be viewed at higher resolutions. HQ isn't really a concern with the DOSBox stuff (they're 20-year-old EGA games, what do viewers expect?), but being able to offer at least 360p with slightly newer games such as Heroes Chronicles would be nice - eventually.)
  • CatherineMcClarey,

    The "p" is the height - so 360p is a 640 wide by 360 high recording. 480p is 856 wide by 480 high. YouTube likes bigger than that, even - 720p is 1280 wide by 720 high. See http://camstudio.org/forum/discussion/comment/3267#Comment_3267

    Be forewarned that sometimes, with some cards, the fixed region has to be reduced by one pixel for it to work correctly, as a pixel is added in for some reason that has been a persistent problem since version 2.5 - not on all machines, but on many.


  • Thanks for explaining about what 240p/360p/etc. mean!
    I used the link from your ScreencastTutorial blog to find Jawor's Xvid and downloaded it from there. (I did appreciate seeing a screenshot of exactly how to configure Xvid within CamStudio (maybe I understand things more quickly if I see both text & pictures?), as well as recommended settings specifically for gameplay video capture.) I did see a "StatsReader 2.1" screen (something to do with Xvid, I think) appear briefly on top of the game window being captured (and then hide itself behind the game window once I clicked in the game window); however, this evening's test recording using Xvid still showed a "black screen" when being played back (with CamStudio's own Movie Player 2.1).
    If I can get Xvid working, that would be great; however, at least Cinepak works for me (and is apparently a big improvement over CamStudio Lossless 1.4).
  • CatherineMcClarey,

    Well, heck, don't use CamStudio's own media player - that is a very rudimentary player. However, I do have to use Any Video Converter to make my vids into MPEG-4 Custom versions for them to play on all media players everywhere - but that's only important if I'm sending them direct as a package to folks, not to YouTube, who perform a custom conversion to MPEG-4 on their own.

  • (... in fact, I used to upload to YouTube in "Private" mode just to take advantage of their conversion, then download from the Video Manager using the drop-down menu alongside each video to get converted MPEG-4 vids for clients.)

Sign In or Register to comment.