Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Video/Audio glitch

edited August 2011 in Announcements
When I choose 'record from microphone' it only records the audio without the video. It records the video only when the 'Do not record audio' option is chosen, which is fine.

How can this be fixed so it records both audio and video at the same time?

Thanks in advance for your help.


  • You might want to have a look at a couple of Terry Britton's tutorials at the following link: http://camstudio.org/forum/discussion/630/how-to-use-camstudio-video-tutorials-now-available-at-youtube#Item_12

    Tutorials 8 and 9 should have application to what you're asking.
  • Hanan,

    Also, what codec are you using? (The compression type for the video).

    Are you using MCI to record? I recommend you always use that.

    Thanks, Jo, for the reference to my vids!

  • Teryy, I'm using MC1 to record.

    When I choose "Do not record audio", it records the video only, which is fine.

    When I choose "Record audio from Microphone", it plays back a blank video with the audio, i.e. records audio only without video.

    Any suggestions to fix this?

  • Hanan,

    This is extremely odd, because when you check "Use MCI to Record" it bypasses any processing for the audio and uses the system audio settings straight in, acting as a simple audio recorder at 16-bit, 44.1kHz sampling rate. I wonder if the video codec you are using is having a problem here? Or perhaps some setting in your system audio control panel??? (That is a stretch!)

    Try with the Microsoft Video 1 codec (a very basic compressor) or try to download Xvid from Jawor or from the Xvid site (I prefer Jawor's version - google "jawor xvid). Make certain you install the 32-bit versions of these, as CamStudio is 32-bit and requires these to operate.

Sign In or Register to comment.