Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Does this file size seem about right?

edited February 2012 in Support
I'm not very familiar with recording videos.
I was planning to use CamStudio to record some game footage, and later upload it to YouTube.
I have the Lossless Codec 1.5 set at a quality of 60 and max framerate as according to auto-adjust (frames every 5 ms).
I recorded a video of slightly over a minute and the size was 190 MB. Seems rather large but I'm not sure.

Comments

  • The lossless codec is not an ideal choice for recording game footage. You would be much, much better served to go get Jawor's Xvid 32-bit version. MANUALLY adjust the "Set KeyFrames Every" setting to 30-100 for that, Capture Frames Every to 25, and Playback Rate to 40 and you should be good to go.

    http://jawormat.republika.pl/xvid.html

    Be certain to set your quality to 1, select the HD720 profile for most of the ideal settings to be already made, and click the "Other Options" button at the bottom and un-check the "Display Encoding Status Window" checkbox.

    Terry
  • Also, record your audio using MCI in the Audio Settings for Microphone area. You'll get good sync then.

    Terry
  • I have 64-bit Vista, so would I want his 32/64 exe then?
  • Yes, but mostly the 64-bit versions will only impact you if you are actually USING the 64-bit Windows Media Player and, perhaps, the 64-bit version of VirtualDub, which are the only natively 64-bit media programs that I know of. Do you know of any others?

    Terry
  • IDK.
    I'm using Media Player Classic, maybe that's part of the problem--I put all the settings as you suggested:
    Key Frames at 30, Capture Frames at 25, and Playback at 40.
    I got no video, just black screen, although audio was still working, and for some reason the media player was opening at a really small size. Not sure why since my CamStudo's region is set to full screen.
    I also tried Key Frames at 65, Capture Frames at 40, and Playback at 25, just to test, with no difference. I tried it both in and out of the game just on my desktop, but it was the same regardless.
  • edited February 2012
    I haven't used Media Player Classic in quite a while, so I have no input on that. (Come to think about it, I think I un-installed Media Player Classic exactly because it didn't work correctly with my CamStudio videos...!)

    The VLC media player used to have problems with CamStudio videos due to an admitted bug in their program that they recently fixed. I like the new Windows Media Player quite a lot, and also use others like RealPlayer (which sometimes has troubles like you are describing - on and off, for some reason, depending upon the updates...)

    Are you sending these to YouTube as the end result? Or Vimeo or some other online host? Or are these for sharing as files?

    I just ask because YouTube's encoding seems to fix lots of things. And you can download the file they create as an MP4.

    Also, VirtualDub will load a video that is AVI-1 like the CamStudio format still is (not much longer!) and will export it as AVI-2, if I heard that correctly. Probably the other converters do the same thing, as AVI-1 is deprecated to AVI-2 for quite some time now, from what I've picked up reading the programmer's comments.

    Terry
  • It was the player.
    Windows Media Player is running them successfully, although for some reason Classic is still opening/running new videos even though I changed the default player. Maybe a restart will fix it.
    Youtube is the end result, yes.

    The only remaining issue now is my mic, it's oddly quiet despite being at 100 and having a 30db boost. It's always been fine on VOIPs and Skype and the like, not sure why it seems so quiet on CamStudio; maybe because of how you have to set up the audio--the microphone isn't being listened to directly?
  • If you are including the mic in a Stereo Mix style recording, then you have the mic's volume AND the Stereo Mix volume control as a chain. Watch that Stereo Mix volume, as it is often easy to set it too high. In that case, the microphone's volume would be set in the Playback Controls rather than the Recording controls.

    Otherwise, I cannot imagine what would lower the volume, as the "Use MCI to record" setting uses system audio directly. If you use the little sound recorder in Accessories, does it record ok?

    Terry
  • Oh wait, now it seems better. Hm, weird.

    Maybe I just have to turn down the game volume and make sure to use WMP, for some reason Classic has a lot of static in its sound when I use it.

    Also, I can't seem to get recordings of game footage that aren't jerky. 25/40, or even something like 10/100 still look jerky when I play it.

    On the plus side, the file size has gotten better. Looking at around 5mb for 20 sec now, as opposed to 20mb.
  • The old "Classic" used to work just fine, but I've had no luck with it for over a year now. As I said, now I recall that is why I uninstalled it (installed it with the k-lite mega codec pack).

    The problem with recording games with a ton of scrolling motion in them is that every pixel is changing. You can try setting the capture key-frames every setting lower, to 30 or so, but your file size goes up, because that is forcing it to capture entire screens for the frames more often rather than trying to capture only what has changed. Either way, games are a challenge!

    Plus, if you try setting priority too high in the Program Options area, it can slow down the game. So, it's a balancing act.

    Have you tried setting Xvid to higher quality setting numbers (lower quality...)?

    You are definitely pushing your processor to accomplish this, so you'll have to find the right balance for your system now.

    Terry
  • The processor isn't being pushed, Enclave is a relatively low-end game, it was released in 2003 for the Xbox and PC. With both Enclave running and CamStudio recording I'm only looking at about 50% of my processor.
    I did seem to get some better recording when I set the Xvid settings to real-time recording (I'll try the lower quality a bit later), the filesize is around 32mb for a 1:40 clip now.
  • That sounds good! Keep me posted!

    Terry
Sign In or Register to comment.