This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

WaveoutGetSelectControl() failed

I get this message when I try to set the recorder to record the sound coming from the speakers. What does this error message mean? I am on version 2.0


  • It means that CamStudio (for whatever reason) isn't able to find the line needed to record audio from the speaker and then generates that error message.

    Compatibility doesn't seem to have anything to do with whether a soundcard is separate or on-board (part of the motherboard).

    There's no programming fix for this as yet, because the source code for that feature was never included in the 2.0 release - which is why it's missing in 2.5b.

    If we can figure it out, maybe we can add it back in a future version, but in the meantime ...

    Try switching to Stereo Mix (or What-U-Hear in some soundcards) as your Recording Input Source.

    In CamStudio go to:

    Options > Audio Options For Microphone > Volume

    Select the Stereo Mix or What-U-Hear option and try it again. You might have to adjust the volume setting as it can be a bit sensitive.

    Also remember to physically remove your microphone from the soundcard if your voice is not required.

    If you don't see Stereo Mix, What-U-Hear or similar, you may need to active that option in Audio Properties.

    Double click Speaker icon in System Tray > Options > Properties > Adjust Volume For Recording > Select Stereo Mix, Mono Mix, What-U-Hear, etc.



    Nick :o)
  • edited August 2008
    I'm getting the same thing in Vista and just used the tip in the microphone settings that you recommended. IT WORKS!!!! Thank you a million times.
  • This Stereo Mix method worked for me, thanks for posting it, I was beginning to think CamStudio had become useless. In CamStudio's Audio Options For Microphone I had to choose "Default input device". I also had to unmute the Stereo Mix source in Volume, as it was set to be muted when it first appeared.
  • Hi. I can't get sound, and I'm trying to use all sorts of things. I have vista.
    I can't see What-u-Hear etc. and when I press the Volume button, nothing happens.
    How can I get sound when recording film!?
  • Hey droote,
    first of all sorry for my bad English. Figured out the same problem as you and was working on it since several hours. I guess I have found a solution.
    Sometimes with Windows Vista you won't see an option for "Stereo Mix". It's not that the option's been left out of Vista, Microsoft just decided to hide it.
    Here are some instructions for enabling Stereo Mix (sometimes also called Wave Out Mix)recording:

    1. Select "Sound" from the control panel.
    2. Select the recording tab.
    3. Right click on the background of the tab and choose "show disabled devices".
    4. Right click on Stereo Mix and click enable.
    5. Make Stereo Mix as your Standard
    6. Now it should work, allowing you to record any sound your computer makes.
    7. Start Cam Studio
    8. Go to Options\ Audio Options for Speaker
    9. Choose at Soundcard Device "Stereomix"
    10. Go to Options and enable "Record audio from speakers"

    After that I still got the error message but I ignored it at this time and It worked !!!

    Try it !!!
  • Woedge

    Thanks a lot for posting that - I tried it on my HP76735s laptop (Vista Home Premium) and it worked perfectly.

    You are a LEGEND!

    I'll make a video for this procedure and put it on my YouTube channel so other non-techie people can see exactly how to do it.


    Nick :)
  • Woedge
    Thanks a million! that worked! You saved my life!
  • Nice, I have been able to get sound now as well. But if I choose "Record sound from speakers" or "Record sound from Microphone" I don't get any output video.

    All seems fine when I record, it displays the region and the size shows up while recording. If I set camstudio back to not to record sound video is recorded just fine.

    Seems like if I record to swf I get both sound and video.

    I tried two different codecs, Divx 6.8 and Xvid MPEG4.
  • Nevermind, it was just WMP classic that didn't want to play the file with Audio. VLC played the file just fine, after a recompression in virtuadubmod the video plays fine in WMP classic too. Sorry for the disturbance. :)
  • I tested Woedge's solution and it also works on Vista Ultimate. How do you guys think it would be best to change to GUI to make this more obvious?

    I could combine all of the record options to the same menu where you just have the ability to select the recording device (ie internal mic, USB mic or the sterio mix). I think this would be a better interface for people with this problem, but it would probably break backwards compatibility.

    I could replace the record from speakers selection with an automatic test to see if it can find an input device that string compares to sterio mix, and then to post these direction if that fails. This seems britle and also possibly not backwards compatible.

    Has anybody has this issue with a computer with XP? If the problem is as simple as Vista vs. XP then I can just add a check to see which version of windows they are using and then display the new GUI or the old GUI. If its not just XP vs. Vista, does anybody know exactly what the difference is so that it could be used to determine which GUI to display?

    Is there another better way that I havn't considered yet?

    Since we've found a solution to fix at least some of the issues, I want to try to fix this in the progam, but I'm not sure the best way. Let me know what you guys think.
  • im using windows 7, on my desktop PC if i
    3. Right click on the background of the tab and choose "show disabled devices".
    i get the stereo mix visable

    but on my latop i only have Line In, and 2 Microphone with show disabled devices enabled!

    what now? lol
  • I followed Woedge's advice, and it solved my problem. Thanks! However, there is now the slightly annoying problem for me that when I play back the video, the audio is much quieter than when it actually occurred. How can I adjust this? I am using a laptop with Vista. I use headphones, but the problem is the same whether or not they are plugged in. I tried adjusting the slider in the levels tab in the properties of Stereo Mix in the Recording Devices list, but bizarrely it always seems to revert back to 20 whenever I change it, hit OK, and check back.

    Thanks to anyone who can help me.
  • Woedge's fix worked for Windows 7 as well.
  • edited December 2009
    On my laptop and many other computers with a built-in sound card, "Show Disabled Devices" does not work to display Stereo Mix as it is not supported, and the built in sound card can't be upgraded.

    I used the 3.5mm to 3.5mm audio cable that came with my iPod to connect my headphone (out) jack to the mic (in) jack to successfully record the audio from an embedded flash video. I had to record few test clips to adjust the volume level as it is very sensitive with this method. A master volume level at 25 across all devices and applications turned out very clear loud sound without hiss or distortion.

    Also, the wiki was very helpful in getting the audio properly synced to the video. I had very good results with a playback rate of 25 and the Capture Every set to 40.

    Also, to get the "record audio from speakers option", download the older Camstudio Version 2.0 (from
  • Hi. I've just downloaded CamStudio and I also get "WaveoutGetSelectControl() failed" when I try to record audio from speakers. I'm running CamStudio 2.0 on XP, and the only options I got in Soundcard Device are "Realtek HD Audio output" and "Realtek HD Audio input".
  • YESSSSS!!!!!

    For people using Reltek HD Audio Input and not able to get any volume, I have a solution!!! You need to enable stereo mix from the Audio Manager and then unmute it!:

    1. Enter the Reltek HD Audio Manager.
    2. Click on the "Mixer" Tab.
    3. Under the "Record" section you will see a little spanner, click it.
    4. Make sure "Stereo Mix" is checked and click ok.
    5. Then, in the "Record" Section look for "Stereo Mix" and unmute it!

    Problem solved!

    This worked with "Reltek HD Audio Input" on XP sp3.

    I hope this helps, it sure helped me!
  • Just had this possible solution for the problem on XP sent in to me by "Steve R" ...

    Control Panel > Sounds and Audio Devices > Audio Tab > Sound Recording box set to your sound card > Start > All Programs > Accessories > Entertainment > Volume Control > Options > Properties > Recording > Select Wave/MP3 and make sure it's not muted.

    Can any XP user verify this works?


    Nick :o)
  • edited March 2010
    I am an xp user and that's what i get when i try to record audio from speakers. WaveoutGetSelectControl() Failed. How do i record from my speakers?
  • mylexis, which of the solutions from this thread did you attempt? What happened when you tried them?
  • Hi,

    I'm also getting "WaveoutGetSelectControl() failed" when I try to record from Speakers. I really need this function, so Im on the verge of buying some someware to do this, but I'd rather contribute to the author to sort this.

    I'm following the VIsta instructions from Woedge, but I'm using WIndows 7 and I don't get the Stereo Mix option in Recorder Devices. When I right click and select Show disabled devices, no new devices appear. The only one listed is "Microphone - High Definition Audio Device".

    Can anyone offer some advice please?

  • After following the advice from Woedge, it still isn't working for me. I have Vista and my problem seems to be either/or. I either don't have audio or I don't have speaker sound. I've looked across the internet for some tips or tricks and ran across this youtube video that shows how to make it work with Vista. Here's the link: the guys voice is kind of hard to hear, so you may have to turn up your sound. Now I followed exactly what he was doing (which was the same as Woedge), up until you going in "Speakers"- "Preferences"- "Levels Tab" and it seems that I don't have any of the other options he is having. (Oh by the way, I also have Realtek) All I have is something called "PC Beep", and I think that could be my problem... It seems like I need the "Microphone" slider. Any idea what could be wrong?
  • This worked for me on Windows 7 and Vista (both 64 bit & using version 2.00 )
    In CamStudio
    audio options
    Audio options for microphone
    Stereo Mix

    Use MCI Recording (Box Checked)

    The one side effect I had was the built in mic & the speakers were recorded on my laptop!!

    Hope this helps,
  • Nope, I just think that the camstudio isn't recognizing my microphone while Stereo Mix is selected.

    However, someone helped me with downloading a sound recording program to use (Audacity) for the microphone sound and have CamStudio just record the video and the sound that would be found in the video. The only problem is synching up the two programs (which without any editing experience is a little hard) to make a new video. I don't really want to deal with Audacity but if I have to then thats fine and great.
  • Hello,

    I recently got a new laptop with Windows 7 because the monitor light for my old Windows XP one died, and I ran into the same error message with CamStudio version 2.00. Stereo Mix/What U Hear/etc. didn't show up after showing disabled devices under "Recording devices." Some Web searching revealed that several computer manufacturers (Sony, in my case) apparently have the sound card manufacturers completely disable that function. This is supposedly an anti-piracy measure, but, of course, it also interferes with legitimate uses. This may be one reason why some of us do not have that option.

    The news isn't all bad, however. You can use the trick posted by asg9000 above. There are also some pieces of software out there that may let you capture the audio by setting up a virtual device. Two examples are "Virtual Audio Cable" by Eugene Muzychenko and e2eSoft's "Virtual Sound Card." These are both shareware, however, and the registration prices may be more than the cost of those cables. On the other hand, I read that the cable method may cause some quality loss, but I haven't done any comparisons myself.

    Finally, there's a solution that the CamStudio devs may be able to incorporate into the program. Vista introduced something called WASAPI that handles audio and lets you capture whatever the computer outputs (probably with some limitations). I found a blog by one Matthew van Eerde ( with a sample program and code, and it worked during a few short tests on my laptop. Again, I don't know the limitations of this compared to the Stereo Mix method or the other options, but it may be better than nothing.

    I hope this helps someone,
  • Hi Dacicus

    Thanks for the link to the WASAPI code, I'll check it out to see if it can be used.


    Nick :o)
  • edited June 2010
    I thought everyones comments were helpfull, but for some reason i cant get my volume button to work.I go to record audio from mic options and click the volume button, and nothing happens.
    I have uninstalled/reinstalled several times and still it doesnt work.If anyone could help it would be highly appreciated.
  • minrain,

    The volume button in Camstudio does not work by default.

    You have to adjust the volume manually by going into:

    For Vista:

    1. Start
    2. Search Sound
    3. Hit Enter

    If you are using a microphone:

    1. Go to the Recording tab
    2. Click on Microphone
    3. Click Properties
    4. Go to the Levels tab and adjust the volume

    If you are using Stereo Mix:

    1. Go to the Recording tab
    2. Click on Stereo Mix
    3. Click Properties
    4. Go to the Levels tab and adjust the volume

    Thanks =)
  • Hi;
    first thanks for helping out how to get the sound recorded on videos.
    My problem is now I can't see the recording anymore...
    Or I chose don't record sound and I have video, or I chose sound and I don't have video...
    Can anyonve help me and solve this problem
  • 2PAC-M4K4V3L1,

    When you don't see video, do you at least hear sound?

    Try 2 things - Camstudio lossless codec for video and check "Use MCI for Recording" in the audio settings. PCM compression, 44,100 K 16-bit stereo

  • 2PAC-M4K4V3L1 --

    Or you might try running the file created by CamStudio through VirtualDub (free download - just Google the name). When I first discovered and started using CamStudio for screen captures, I didn't have the problem you describe, but later for some unknown reason I did. In every instance VirtualDub has produced a usable file with both video and audio with little if any degradation of video quality. I realize this is sorta ducking the problem, but although I don't know what causes the problem, what I'm interested in is a usable file, and VirtualDub has enabled that result.

    In addition if the need should arise, VirtualDub makes usable files greater than 2GB in size (set video to Direct Copy -- audio is already set that way).
This discussion has been closed.