Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Recording settings help

Hi all,

My sincere apologies if this is covered in another thread - I couldn't find it. Please point me in the right direction if it is!

I am trying to record a full screen without audio (1920x1080), using CamStudio 2.6, but am getting very jerky playback. The picture quality is excellent, it just plays back like a time-lapse video. I have been googling like mad and tried several sets of different settings and downloaded both the XVid and DivX codecs, and the best I have managed is a slightly jerky, what I might guess at is something like 8-10 frames per second, playback. The worst have been hilariously unwatchable.

My computer is a brand new PC with Windows 7, a good graphics card and 16GB RAM. I'm also sure to make certain that CamStudio is the only thing running, so I don't think it is a resources issue. Here are a few of the settings I tried (Key Frames / Capture Frames / Playback rate):


There were several others, but I can't remember what the settings were - random ones I made up to see what effect they would have. Any advice you can offer on what settings to input to get smooth playback, at as high a quality as possible, would be much appreciated.

Many thanks,

P.S. I remembered I tried the Lagarith Lossless Codec too, but it won't play back, and Microsoft 1, which was awful.


  • Your computer certainly has enough resource to run Cam, but that may not be what's causing the problem. Keep in mind that CamStudio is never "the only thing running". You're also running Explorer and whatever software is being used to play whatever it is you're recording. Here's a simple test to get some idea of where the bottleneck is. First, set your video options to Xvid MPEG-4 with the capture/playback set to 5/200. Now start a static full screen capture (just your desktop with nothing running) and see what the "Actual Input Rate" is. On my computer, with way less resource than yours has, it's well over 100. On yours, it should be close to 200. Now repeat the test with whatever it is that you're trying to record running. If the Actual Input Rate drops below 40, you're going to have a tough time recording smooth high motion video with any setting, and you'll most likely need to scale down the capture area to bring the input rate up to usable levels, or attempt to find different software to run whatever it is you're trying to record.

    Your playback rate will always be the same as the FPS on your output video, so the Input Rate is really nothing but a barometer of the general health of the recording process. After you've captured at 5/200, you'll need to convert the 200 FPS to 30 or less to make the file playable on media players. I use a video editor to convert, usually to MPEG2, while others use something like Any Video Converter to change to MP4. The important thing to remember here is that media players will attempt to play anything you throw at them, but they have problems properly rendering material which has a frame rate of greater than 30.

  • Hi Ken,

    Thanks a lot for that - I'll give it a try and report back :)

  • Hi Ken,

    Mmm... this is very strange. The 'Actual Input Rate' with nothing running (except this internet explorer window to read your instructions) is around 15fps, which seems crazily low! What on earth am I doing wrong?

    Many thanks,
  • The first thing to do is start CamStudio again and have a look at which codec it is actually using, as opposed to what you have it set to use. It should say “Codec: Xvid MPEG-4 Codec” while it is recording. With a lot of stuff running on my computer I can slow the “Actual Input Rate” down to around 42 at full screen, and yours should be higher IF you are actually using the MPEG-4 codec.

    If Cam shows that it is indeed using the correct codec, the problem most likely lies elsewhere. In terms of stealing resource, the two biggest culprits are a A-V program and Adobe Flash Player. You need to be sure that both of these are shut down by checking in Task Manager. Note that after you’ve run Adobe it keeps running even after you’ve finished with it, so you need to manually shut it down or restart your computer.

  • Hi Ken,

    Thanks for you help and persistance so far.

    That is indeed the codec it is using. I have no idea what the hell is going on and feel like giving up. So many people do this - how can it be so hard? I have a 3.4ghz quad-core processor and 16GB RAM in a computer that cost me £1100 last week. How can I be having resource issues? I just don't understand. I have tried Screen Virtuoso too - the recordings from that seem to record ok, but windows media player and Realplayer play them is super fast-forward!? Eh!?

    Any help from anyone would be very much appreciated.

    Yours dejectedly,
  • Me again.

    I have just noticed that CamStudio has stopped saving the files it records too. *Sigh*

  • edited August 2012

    You are having an inordinate number of problems.

    Please see this link - it may help.


    The fact that other programs are acting strangely may point to custom settings in the video driver's control panel. Set then to defaults and try again. Things like 3D rendering settings when you are not using 3D and the like can slow your screen's capture rate. Try setting it to 24 or 16 bit video. Try anything!

    The program doesn't typically just decide to stop saving the files it records. Check that the folder you've selected is write-able without having to be an admin. How are you saving them? Do you have "Ask for Filename" selected?

    We'll get you running eventually. Sorry you are having to slog through so many pitfalls.

    Thanks, Ken, as per usual! :-)

  • Hi Terry,

    Thanks for your reply.

    I have reinstalled Cam Studio now and it is saving videos again where I tell it to (it seemed it had been saving them in a folder in the /Program Files/CamStudio folder, even though I had asked it to save to an external hardrive). However, when I removed that codec pack I mentioned, it seems to have removed/messed up XVid too - certainly although my system tells me DivX is also installed, I am no longer able to see either of these codecs in the Video Options menu. I have reinstalled the 64-bit XVid from the link in the thread you posted above, and still no luck.

    I notice that in your video, you have 2.6c beta, which solves problems with finding codecs (have I got that right?). I have found a 7-zip file of 2.6c to download, but am not able to install it - I have clicked all the applications in the unzipped folder and none of them is the recorder or an installer for it - apologies if I am missing something!

    I can still record with the codecs listed - Microsoft Video 1, Intel IYUV codec, Cinepak Codec and FM Screen Capture codec. The results I can get from these have an 'actual input rate' varying from 1.5fps to about 5.5 fps and still look awful!

    I'm not sure what you mean about the video driver's control panel. Where am I likely to find that?

    Sorry for all the questions and thanks again for your help.

  • Ah! Apologies. I didn't install the 32bit version too, which I have now done. XVid is back as an option. I've followed your setup and have an 'actual input' of about 8.5 fps. It still produces very jerky videos unfortunately.

  • Most of the other codecs you mention are pretty slow and mostly unusable, but those numbers are very low, even for those codecs. Terry and I both use Jawor's version of Xvid Mpeg-4 which can be downloaded at


    You'd need either the 32 bit or 32/64 bit version. But since everything is running low, that might not be the solution. The next question I'd have concerns the capture areas you've tested so far. That 1920 x 1080 resolution jumps out at me, because it's uncharted waters as far as my experience goes. I'd be curious to see how the Xvid codec performs on a smaller capture area. One quick test would be to set the fixed region to a small area, say 512x288 (511x287 if Cam asks you if you want to use the default compressor). If the numbers jump back up to normal, there's something wrong with the relationship between Cam and what it's reading as a full screen capture, and there may be a problem with exactly how "full screen" is interpreted by your graphics processor. All screen capture programs will malfunction if they are asked to record an area larger than that permitted by the actual display size.

    Secondly, you mention getting the same bad results in your latest tests. I assume that means you're actually recording something with motion, and that brings up two issues. First, if the recorder isn't functioning properly on a static screen, it has no chance of capturing any type of motion smoothly. Secondly, you're using a program which is generating the motion you're recording. I should repeat that if the program is Adobe Flash, the latest version is a real monster in terms of hogging resource. It will take everything available to it, and then some, and there seems to be no reasonable way of choking it down without causing it to crash.

    Anyway, I'd try the small test area of nothing but the desktop to see if that works. One really good way of testing codecs setting for motion capture, etc. that I've found is to play a short clip using MPC at 640x480, capture it, process it, and play it back side by side next to the original. Using the settings I do, it's simply impossible to tell the difference - the motion and image quality are both perfect. (If I open a process that uses Adobe Flash and try the same thing, the results are okay, but not as good.) As a test exercise, settings of 50/20 or 40/25 should work well, because the resulting AVI will be playable on media players, although the motion will be compromised somewhat.

    In answer to your question, you can access the graphics properties on Intel machines by right clicking anywhere on the desktop and selecting "Graphics Properties".

  • Lee,

    Also, to add to what Ken has told you, the 2.6c beta does not have an installer - it simply creates a folder where the program files exist. It needs the 2010 version of the Microsoft C++ Runtime libraries as well.


    I'd have to agree that going for a 1080p recording is going to SWALLOW resources like crazy, especially for a high-motion recording. So many pixels!!!! Try 1280X720 (1279X719 if Cam asks you if you want to use the default compressor) - that setting works great with YouTube as HD!

  • edited August 2012
    Thank you very much both - much appreciated. I'll try this over the weekend.

Sign In or Register to comment.