Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

RealTek HD Audio does not work



  • DoubleYou,

    Of course! I hadn't thought to warn people to use the 16-bit, 44.1kHz settings.


    Thanks for the update on the Toshiba BIOS and drivers - it looks like they decided not to buckle under the pressure from the RIAA.

  • I have to uncheck the "Stereo Mix" and recheck it after a restart every time. It a total pain; Is there a way around this?

    I went into sound in the control panel did a test and no sound was being picked up.


    1.opened realtek HD Audio manager from control panel
    2. clicked the mixer tab
    4. clicked the spanner under microphone
    5. checked the the box to "Stereo Mix"

    It worked then stopped working after restart. I then had redo the above steps this time uncheking Stero Mix click OK then re-check stereo mix to get it working....

    I have to do this after every reboot

    Any help would be great
  • edited February 2012
    Is this in XP? If so, there might be another program trying to control your input settings. GoToWebinar will do this if the host un-mutes you (change the setting to microphone).
  • Hi, what is webinar?
  • edited February 2012
    A webinar is a live presentation where a subject (or several subjects) are usually covered in depth. The word is a combination of "seminar" and "web". We have a 2-hour webinar on CamStudio I gave a while ago at YouTube - here it is!

    (Watch it at YouTube or here full screen at 720p for the best effect...)
  • hi guuys I am using windows XP and I had the same problem but I fixed it. Now a new problem appeared. I can't record sound more than 5 minutes becuase the error "Failed to rename/copy audio file" appears. Why? And how can I fix that?
  • razputin100,

    Take a look where the temporary files are being stored and delete all of those - or change the directory where your temp files are placed to a directory outside the program files folder (like in the My Videos folder, where I have created a "CamStudio Temporary Files" folder just for that purpose). I also, when uncertain whether I've gone overtime or not, COPY the temp files to another folder within that folder called "FailSafe copies" before I hit the "Save" button (after the save dialog comes up after I'd pushed the stop button). That way, if CamStudio crashes when trying to compile the temp files into an AVI, I at least have the raw materials that I can attempt to rescue in VirtualDub later on.

    Let me know if it is something else, though, that is giving you these issues.

  • Well it got worse. I get this error after I save my videos no matter how long the video is. But something new appeared. The sentence "File creation error" made me think it is another error, but I think it isn't.
  • razputin100,

    Are you using "Record from Microphone"? Also, where is your temp directory, exactly? Plus, are you certain there isn't a file already with the same name in the folder you are saving to? Sometimes it will not write-over an existing file.

    We'll get this working eventually - 100's of people do use this program, of course! So, it is probably something simple we are overlooking.

  • Terry,

    I have done what you said and moved my folder in wich I keep my videos and it worked. The problme is that I need to make a montage and I recorded yesterday around 15 minutes. The problem is that an error says that camstudio can't open the videos wich are in that moved folder. And because of that windows media player can't play those videos too. I think there is a problem too because I changed my losless codec to Microsoft1 after I watched a video on youtube wich was done by you. I will try to put the Losless codec back to Camstudio 1.5.
  • razputin100,

    Please Please Please!

    Do not use the CamStudio Lossless codec (or ANY lossless codec) if you are needing to record videos of any length over 9 minutes. It is a total waste of space to record full-frame recordings in stellar quality for every frame of most videos. You are likely going over the 2-gigabyte file size limit in mere minutes, instead of hours, like Xvid and others would allow you to do.

    Follow my 2012 video linked to in the sticky posts here up top and install Xvid. Microsoft Video 1 is the worst codec imaginable, so I do not recommend that one at all.

  • I'm using Vista Home Edition with Realtek Audio, I went into Control Panel, & went to " Sounds " icon, & there are 3 tabs ( Playback, Recordings, Sounds ) select Recordings tab, in this box you will find your , Microphone, Line-In, and Stereo Mix....... for some reason, if your going to narrate a video, select Microphone and "set as default"..... if your recording a video game without a microphone, then in the Recordings tab folder, select Stereo Mix.... now make sure there are green check marks there ........ you will have to toggle between these settings in the control panel.... but it works.
    I have not figured out how to do Stereo mix and Microphone at the same time with Realtek.

Sign In or Register to comment.